ZEISS support page for cyber security information

Please update your ZEISS device.

October 2021

Java Deserialization Vulnerability Cybersecurity Update (CWE-502)

for ZEISS FORUM

September 2021

Microsoft Windows Print Spooler Vulnerability CVE-2021-34527 (“PrintNightmare“) Cybersecurity Update

For ZEISS ATLAS, ZEISS CIRRUS, ZEISS CLARUS, ZEISS HFA3, ZEISS PLEX Elite, ZEISS PRIMUS, ZEISS IOLMaster, ZEISS SL Imaging Solution, ZEISS SL Workstation, ZEISS VISUCAM and ZEISS VISUPAC

Click here

to get direct assistance from our service team.

Stay up to date

Sign up for updates on current topics, news and events.